Jump to content


Photo

win8/8.1 fix


  • Please log in to reply
59 replies to this topic

#26 Iran

Iran

    Seal

  • Members
  • PipPipPipPip
  • 133 posts

Posted 28 December 2014 - 09:47 PM

Thanks for the report.



#27 CoLoKurT9

CoLoKurT9

    Seal

  • Members
  • PipPipPipPip
  • 104 posts

Posted 30 December 2014 - 12:05 PM

Hosting a game is also a nightmare with this file for me at least. Not sure if this helps you at all or not, just saying what isn't working



#28 Babak

Babak

    Commander

  • Bounty Hunters
  • PipPipPipPipPipPipPipPip
  • 13030 posts
  • Location:Australia
  • XWIS Name: Babak

Posted 30 December 2014 - 12:30 PM

EDIT: I'm trying YR on W8.1 and when you join a game in the lobby the screen looked messed up, and you can't see the options you're picking. I tried to take a SS but it doesn't capture it properly


Edited by Babak, 30 December 2014 - 12:50 PM.


#29 Olaf

Olaf

    Commander

  • XWIS Admin
  • PipPipPipPipPipPipPipPip
  • 13438 posts
  • XWIS Name: XTF

Posted 30 December 2014 - 12:52 PM

Disable display scaling in compatibility options.

#30 Iran

Iran

    Seal

  • Members
  • PipPipPipPip
  • 133 posts

Posted 30 December 2014 - 03:51 PM

Please do what Olaf suggested and please report here whether the issue still happens after doing that or not.



#31 CoLoKurT9

CoLoKurT9

    Seal

  • Members
  • PipPipPipPip
  • 104 posts

Posted 31 December 2014 - 09:05 AM

I have recorded a video of what it is like (for me at least) on windows 8.1. This is with the file you have provided us and with "Disable display scaling"

 

http://screencast.com/t/uBFFWqMIE         (there is a fullscreen option that will resize the video for your screen on the bottom right.)

 

The beginning is odd, the video never shows that I was in the start up screen (I was). Also during this video you can see my desktop during the recording, this was not the case when I recorded it (or ever when I play). The Black Box area is what my monitor is displaying

You will see during the video alt tabbing does not crash the game, but it does screw a lot of stuff up. 

Also some non related (to alt tabbing) issues that are shown in this video. I can ffg with any map, but not tourney with them. I can barely see what I am typing (I showcase this by poking some fun at someone =P), and when I type it does not move me back to a live chat spot. This makes it hard to see what people are saying to you.

 

* I did not play long enough to demonstrate the crash report I was telling you about *

Note that the QM worked, it was a little slow but I was in the process of recording a 60 mb video. Normally faster

 

This is a recording of my settings.

 

http://screencast.com/t/CO1zxN9BnG


Edited by CoLoKurT9, 31 December 2014 - 09:09 AM.


#32 fir3w0rx

fir3w0rx

    Xwis Was Initially Striketeam

  • XWIS Buddies
  • PipPipPipPipPipPip
  • 2158 posts
  • Location:Out with your wife
  • XWIS Name: fir3w0rx

Posted 02 January 2015 - 09:08 AM

Tried this on my nephew's laptop with Win 8.1 and an AMD gpu. It did fix the menu buttons (prior to this we couldn't see any buttons and had to use the lines behind where the buttons would normally be, as a guide :D), but it lagged while in the menu/lobby. But once the game started, the in-game speed was ok though. We decided to remove the file and go back to just clicking blind on the menu (with no buttons) because after a while we memorized where the buttons should be  :D.

 

The fix seems like it's almost there and just few tweaks away from working 100%.


Edited by fir3w0rx, 02 January 2015 - 09:22 AM.


#33 Babak

Babak

    Commander

  • Bounty Hunters
  • PipPipPipPipPipPipPipPip
  • 13030 posts
  • Location:Australia
  • XWIS Name: Babak

Posted 02 January 2015 - 10:35 AM

Please do what Olaf suggested and please report here whether the issue still happens after doing that or not.

Thanks for the suggestion guys, I tried it and it appears unchanged, I took an off-screen screenshot to make more sense (note that in the dropdown menu for "Start" position the options are not visible

 

http://imgur.com/GmxBFQs

 

 

Some other info about computer:

- Dell XPS 15z laptop (with Nvidia graphics card, latest drivers)

- Windows 8.1 (latest updates)

- I also tried the old school fix for Windows 7 where you would add a fake VGA screen to extend the displays, didn't change anything



#34 Olaf

Olaf

    Commander

  • XWIS Admin
  • PipPipPipPipPipPipPipPip
  • 13438 posts
  • XWIS Name: XTF

Posted 02 January 2015 - 12:37 PM

Set Windows Text Size to 100%.

#35 Babak

Babak

    Commander

  • Bounty Hunters
  • PipPipPipPipPipPipPipPip
  • 13030 posts
  • Location:Australia
  • XWIS Name: Babak

Posted 02 January 2015 - 04:10 PM

Set Windows Text Size to 100%.

It's fixed :) thanks Olaf!

 

Also the patch seems to have fixed everything Iran, played a few QM. Epic job!


Edited by Babak, 03 January 2015 - 02:15 AM.


#36 Iran

Iran

    Seal

  • Members
  • PipPipPipPip
  • 133 posts

Posted 04 January 2015 - 12:09 PM

There are some issues with the flickering menus and a bit of screen tearing while scrolling the map though. Also need to know more about performance at higher resolutions, my monitor only supports up to 1280x720..



#37 CoLoKurT9

CoLoKurT9

    Seal

  • Members
  • PipPipPipPip
  • 104 posts

Posted 05 January 2015 - 02:22 PM

I just tried to print screen for someone (since I don't have auto ss) It took a screen of my desktop when I was in the middle of playing...Now the guy probably thinks I cheat.


Edited by CoLoKurT9, 05 January 2015 - 02:24 PM.


#38 ImNewButOld

ImNewButOld

    Lieutenant

  • Members
  • PipPipPipPipPip
  • 928 posts

Posted 05 January 2015 - 02:52 PM

Thats because you run the game in windowed mode

#39 CoLoKurT9

CoLoKurT9

    Seal

  • Members
  • PipPipPipPip
  • 104 posts

Posted 06 January 2015 - 04:03 AM

Thats because you run the game in windowed mode

oh...thanks for the info



#40 Iran

Iran

    Seal

  • Members
  • PipPipPipPip
  • 133 posts

Posted 06 January 2015 - 07:32 AM

Sorry about that, CoLoKurT9. Could probably hijack the 'prntscrn' to create a screenshot later on. The game itself should have a hotkey for creating screenshots in .pcx format, which you can then convert...don't know if that requires using one of the game's palettes.



#41 Strategst

Strategst

    Colonel

  • ST Retirees
  • PipPipPipPipPipPipPip
  • 5796 posts

Posted 10 January 2015 - 05:09 PM

This fixes the game menu, low FPS and alt+tab. It also allows you to play windowed without changing to 16-bit colors.

 

Place this file in your game folder: https://www.dropbox.com/s/598uwf0diwwsthh/ddraw.dll?dl=0

 

It reimplements the game in OpenGL. 

 

Known bugs: Menus sometimes flicker.

 

Can someone test the performance of this fix? Does anyone get lag in-game?

 

Make sure you're running Win 8/8.1. This DLL seems to cause lag in-game with Windows 7.

When I add this file to my game folder, Red Alert 2 and Yuri's Revenge will not launch. I downloaded the games from here and saved the file that you linked to the same folder where I installed them. Am I doing something wrong? I would love to get the downloadable versions to work on Windows 8 so that I can have automatic screenshots. The Origin version I was using before does not have those.

 

Update: I am not really sure how all the settings finally worked together, but after a series of compatibility tests, moving the file in and out of the game folder, and installations, the games finally work. I have automatic screenshots; however, if I am on one screen for too long, I experience extreme lag. For instance, the lag occurs if I sit in the lobby, game or quick match channel for any length of time. If I join a game that starts right away, the game has no problem running. How should I go about fixing this issue?


Edited by Strategst, 11 January 2015 - 04:34 PM.


#42 CoLoKurT9

CoLoKurT9

    Seal

  • Members
  • PipPipPipPip
  • 104 posts

Posted 14 January 2015 - 01:54 PM

Iran, I really like the steps taken with this file. However, RA2 crashes in 10 minutes or less for me if I do not find a game to play, so I cannot endorse this.



#43 Iran

Iran

    Seal

  • Members
  • PipPipPipPip
  • 133 posts

Posted 15 January 2015 - 06:17 PM

Is this in the WOL lobby?
 
Do you also get the lag that Strategst experiences? Where after a time the game starts lagging if you stay in the same menu?

Edited by Iran, 15 January 2015 - 06:18 PM.


#44 CoLoKurT9

CoLoKurT9

    Seal

  • Members
  • PipPipPipPip
  • 104 posts

Posted 16 January 2015 - 08:42 AM

Is this in the WOL lobby?
 
Do you also get the lag that Strategst experiences? Where after a time the game starts lagging if you stay in the same menu?

 

At the moment, any lobby. Once I am in a game, everything is safe, I can do whatever. If I alt tab, I can mess around on my desktop for a couple of minutes but the entire game freezes if I spend more than that. If I stay idle in any lobby or waiting for players in a game lobby, I will freeze. When I wait to find a game, I need to change lobbies or menus every couple of minutes to ensure that the game stays running. I do not really experience lag, it either works or it does not



#45 DaRk

DaRk

    Seal

  • Members
  • PipPipPipPip
  • 440 posts

Posted 28 June 2015 - 01:03 PM

so ra2 still dont work properly in win 8.1?



#46 hardman

hardman

    Commander

  • Strike Team
  • PipPipPipPipPipPipPipPip
  • 10521 posts

Posted 28 June 2015 - 01:12 PM

AFAIK people are running ra2 on windows 8, maybe with a couple of issues but still able to play. Some people have more problems then others.



#47 DaRk

DaRk

    Seal

  • Members
  • PipPipPipPip
  • 440 posts

Posted 29 June 2015 - 01:30 AM

ill just use the red alert 2 i get from the command and conquer collection, that one works with windows 8 

 

edit: shit the collection box ra2 version also don work on windows 8

 

edit:

 

I wanted to thank you iran, i installed red alert 2 on the tablet and i only get sound, then i added your file and red alert 2 runs great on my 50 euro tablet!!! :D:D:D

 

only the menu is laggy, so i was scared the game would lag, but its very fast !

 

thank you very much, now i can play ra2 outside!!  lol


Edited by DaRk, 29 June 2015 - 07:07 PM.


#48 cihan01

cihan01

    New Conscript

  • Members
  • Pip
  • 1 posts

Posted 16 July 2015 - 10:39 PM

It isn't working.

 

I tried everything, but i can't solve this problem.

 

I downloaded a file , it had your dll + some cfg file. When I put that files in the RA2 directory, black screen problem fixed, but still no screen. Screen resolution is getting small, and a small black rectangle in top left. (I can see desktop and other programs)



#49 DaRk

DaRk

    Seal

  • Members
  • PipPipPipPip
  • 440 posts

Posted 24 July 2015 - 01:34 PM

its strange, on another computer i have wich runs windows 8.1, it runs ra2 without any problems or modifications, didnt need your file or nothing.



#50 zenicanin

zenicanin

    Corporal

  • Members
  • PipPip
  • 11 posts

Posted 03 August 2015 - 12:45 AM

Just upgraded to Windows 10.  ra2 didn't work, had the hidden menu problem. Added this file and fixed it all. I can even play yr now! And just to be able to alt tab and come back is amazing.  I can't tell you how many times I played and some notification minimized my ra2 and I couldn't come back in the game.  It sucked!  There's still some issues like the menu flickers and can lag a bit, but in game seems really speedy and nice. Anyways thanks a bunch!


Edited by zenicanin, 03 August 2015 - 01:01 AM.



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users