Jump to content


Photo

Internal Error with Red Alert 2 [Expired]


  • Please log in to reply
28 replies to this topic

#26 nuker7738

nuker7738

    Sergeant

  • Members
  • PipPipPip
  • 60 posts

Posted 06 December 2012 - 10:09 PM

Error code: EXCEPTION_INT_DIVIDE_BY_ZERO

Description: The thread tried to divide an integer value by an integer divisor of zero.
Exception occurred at 005BB2F3


Divide by zero errors are exceptionally rare in the stock game, and unfortunately I have not seen this EIP before myself, nor is it on the ModEnc database of known Internal error EIPs. I will see if I can get a hold of an old developer buddy and have him take a look at it.

But a divide by zero error makes me almost certain that this is a software or hardware issue, and not network related.

The first thing I would try is to remove as many patches as you can and run RA2 as vanilla as humanly possible (that is, with only the patches absolutely necessary to make it work on Win 7) and see if you get any progress-- outside of that, the network card and its TCP/IP stack is the most likely culprit of this error, and the only thing that can definitively rule that out is if you swap in an expansion NIC and test the game with your ethernet plugged in to that.

Edited by nuker7738, 06 December 2012 - 10:10 PM.


#27 salv3tor13

salv3tor13

    New Conscript

  • Members
  • Pip
  • 1 posts

Posted 18 December 2012 - 03:44 PM

I had a very similar issue and it was doing my head in! I would be able to get into an online game, it would play for maybe 20 - 30 seconds and then I get the internal error message. I am running Windows 7 x64.

I opened the Westwood folder and searched for .exe - I then changed each on individually to run in Windows 98 / ME compatibility mode. Now works like a charm :)

#28 FReQuEnZy

FReQuEnZy

    Retired

  • Members
  • PipPipPipPipPipPipPip
  • 7986 posts

Posted 18 December 2012 - 08:06 PM

Those compatibility settings can cause RA2 to forget settings for multiplayer. You should also install the unofficial patch as that works well on windows 7 without any compatibility settings.


Download
http://www.filedropper.com/ccredalert2unofficialpatchv126

Topic
http://xwis.net/forums/index.php/topic/175970-cc-red-alert-2-unofficial-patch/

#29 Gizmo

Gizmo

    New Conscript

  • Members
  • Pip
  • 5 posts

Posted 10 July 2013 - 06:11 AM

I switched my connection to my mobile phone's data connection, but the same internal error still appeared.

I also tried to play without having the Windows firewall on - this did not work either.

Here's the file:

attachicon.gifexcept.txt

I have exactly the same issue, any chance you managed to fix it?

 

Nevermind I fixed it, I was trying to play a mate who was using his phone, and once he changed to adsl, forwarded the ports, and disabled advanced outbound port routing and now it works fine, still not sure why my end was affected with an internal error however I also never tried playing somebody else other than him


Edited by Gizmo, 12 July 2013 - 04:37 AM.



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users