Jump to content


Photo

Yuri's Revenge with TFD 1.03 r4 unofficial patch crash


  • Please log in to reply
4 replies to this topic

#1 Lesterus

Lesterus

    New Conscript

  • Members
  • Pip
  • 4 posts

Posted 17 June 2012 - 12:21 PM

Hi guys, :wacko:

I got YR working on my Win7 x64 system a while ago, with all my motherboard drivers, hamachi and the unofficial The First Decade patch. Everything was working fine back then. Recently I came back to the game and it was working for about 2 days, before suddenly crashing every time exiting the YR game after being in the network lobby or internet lobby.

The crash hinges on the fact gamemd.exe (main executable for YR) hangs when exit is clicked.

The crash would be fine to deal with if i could actually kill the gamemd.exe process. :rolleyes: After it black/grey screen crashes, i cannot use anything on my computer. I open task manager through ctril+alt+del and then kill process tree for gamemd.exe. Even tried using procexp.exe from microsoft tools to kill handles within the process and that didnt work either. :confused1:

This doesnt respond. Nothing can cancel the process except for a cold shutdown or restart. Or waiting 5-10 minutes for it to automatically close (no idea how or why it manages to close it after so long). I heard in another thread this was happening with RA2 and that there was a patch made to address the issue. Since the two games are relatively similar, I would think they would be in coding as well, which hopefully means a patch can be made for YR as well.

It would be great if another patch could be made for yuris revenge because i am out of ideas in terms of fixing this issue and so would other people. My friend has a similar set up and it works fine.

I even used his installation media, after thinking my own installation media could be to blame.

Reinstallation of both the game and my WIndows 7 x64 OS (wipe and load)

All exes are set at windows 98 compatibility, game runs fine for everything until exiting out of network and internet.

I've spent a few days thoroughly poring through forums trying to find anybody else who had this happen, all the while trying as many fixes as possible. This one really has got me.

Any help at all would be appreciated fellas.

#2 ltmcgerty

ltmcgerty

    Seal

  • Members
  • PipPipPipPip
  • 128 posts

Posted 18 June 2012 - 01:15 PM

is there a fix for this on ra2? i get this as well on vista on both my ra2 and yuri games, it also messes my internet up after the game has crashed, so i have to retsrat the whole comp!

#3 Psychic

Psychic

    NRA

  • Members
  • PipPipPipPipPipPip
  • 2734 posts
  • Location:Neither here nor there
  • XWIS Name: PuNiSh3eR

Posted 19 June 2012 - 11:58 AM

try a system restore to a point when it was working previously

#4 Seke

Seke

    C&C Tournament Organizer

  • Help Team
  • PipPipPipPipPipPipPip
  • 6690 posts

Posted 19 June 2012 - 12:20 PM

try downloading the MP version instead, go to the downloads section

#5 Lesterus

Lesterus

    New Conscript

  • Members
  • Pip
  • 4 posts

Posted 25 June 2012 - 10:52 AM

this may not be the fix for you guys, but I found it was my onboard Network interface card's ethernet controller stuffing Yuri's Revenge up. It is a special NIC called the "Bigfoot Killer". After about 2 weeks attempting various fixes I had a thought that it might be my NIC.
I went to the local PC parts shop and bought a regular TP-LINK Gigabit PCI network adapter. Uninstalled the bigfoot killer driver, installed the new NIC into the PCI slot on my motherboard, installed the driver and tested YR. No hangs in network games, all games and players show up in lobby and best of all, no crashing after exiting. :jump:


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users