Jump to content


Photo

RA2 in windows 7 64bit freezes on startup HELP ive tried EVERYTHING


  • Please log in to reply
18 replies to this topic

#1 israel102

israel102

    New Conscript

  • Members
  • Pip
  • 6 posts

Posted 04 September 2010 - 02:51 PM

I am installing red alert 2 on a 64bit windows 7 home premium operating system. my problem is that the game runs, but after it has started the menu shows up and then freezes. as in, the game is running and i can hear it (and press buttons) but the screen doesnt refresh and i dont see the changes i have made. if i go out of ra2 and then go back in, i see the changes i made (but the problem is still there and it "freezes" again). i hope this is clear. game works but doesnt show it. cant see menu buttons. cant see menu changes.

Now, i have tried EVERYTHING. I have run in administrator, changed basically all compatibility and permission settings. i have installed from the multiplayer only file. i have installed from the original disk. i have even downloaded a 8gb c&c TFD and installed red alert 2 from there because i heard it works with 64 bit. I have changed resolutions and made it open in windowed mode. I have never done this much googling in my life. Please, HELP ME!!!

#2 noobLit

noobLit

    Lieutenant

  • Members
  • PipPipPipPipPip
  • 671 posts

Posted 04 September 2010 - 02:57 PM

I had this same problem when I first installed ra2 on my new laptop with Win7. I ended up just reinstalling several times and it finnally worked perfect :confused1: .

I made a topic about it here -> http://xwis.net/forums/index.php/topic/163603-windows7-reso-patch-issues/page__p__1401973#entry1401973 I never changed a thing to get it to work, just reinstalled a couple of times. Not sure if this helps, hope it does......

#3 israel102

israel102

    New Conscript

  • Members
  • Pip
  • 6 posts

Posted 04 September 2010 - 03:00 PM

I had this same problem when I first installed ra2 on my new laptop with Win7. I ended up just reinstalling several times and it finnally worked perfect :confused1: .

I made a topic about it here -> http://xwis.net/forums/index.php/topic/163603-windows7-reso-patch-issues/page__p__1401973#entry1401973 I never changed a thing to get it to work, just reinstalled a couple of times. Not sure if this helps, hope it does......

how did you install ra2? through the disk or through the multiplayer only file? or through some other way? im wondering which way i should reinstall with

#4 NeoGrant

NeoGrant

    Commander

  • Members
  • PipPipPipPipPipPipPipPip
  • 14914 posts
  • XWIS Name: neo

Posted 04 September 2010 - 03:04 PM

Have you installed the tfd patch 1.03 by any chance?

#5 israel102

israel102

    New Conscript

  • Members
  • Pip
  • 6 posts

Posted 04 September 2010 - 03:05 PM

no i have not

#6 israel102

israel102

    New Conscript

  • Members
  • Pip
  • 6 posts

Posted 04 September 2010 - 03:14 PM

should i?

#7 noobLit

noobLit

    Lieutenant

  • Members
  • PipPipPipPipPip
  • 671 posts

Posted 04 September 2010 - 03:49 PM

how did you install ra2? through the disk or through the multiplayer only file? or through some other way? im wondering which way i should reinstall with


I installed it with the TFD cd.

#8 afeenaaa

afeenaaa

    PUDDI

  • Banned
  • PipPipPipPipPipPip
  • 1238 posts

Posted 05 September 2010 - 06:24 AM

Do you have Intel GMA HD graphics? Just curious...

#9 lookslikeyou

lookslikeyou

    New Conscript

  • Members
  • Pip
  • 5 posts

Posted 05 September 2010 - 12:57 PM

I have, and I got the same problem. Is it a driver issue?

#10 israel102

israel102

    New Conscript

  • Members
  • Pip
  • 6 posts

Posted 05 September 2010 - 06:23 PM

i tried installing it again, no luck. at the moment i dont have access to the computer so i cant tell you if i have intel gma graphics. but when i do have access ill post the answer. thanks!

#11 lookslikeyou

lookslikeyou

    New Conscript

  • Members
  • Pip
  • 5 posts

Posted 05 September 2010 - 08:21 PM

still got the same problem as you. I have a i3 proccesor with a intel gma graphic proccesor. Tried 2 different versions. Tried the administrator permission fix. Still got the freezes.

#12 lookslikeyou

lookslikeyou

    New Conscript

  • Members
  • Pip
  • 5 posts

Posted 07 September 2010 - 05:05 PM

sorry for kicking, but any-1 got a solution?

#13 lookslikeyou

lookslikeyou

    New Conscript

  • Members
  • Pip
  • 5 posts

Posted 14 September 2010 - 09:14 PM

Still nobody knows? Only thing I can do is to install Xp or vista?

#14 FReQuEnZy

FReQuEnZy

    Retired

  • Members
  • PipPipPipPipPipPipPip
  • 7986 posts

Posted 14 September 2010 - 10:52 PM

You won't have to install xp seperately. On windows 7 you can run it as a virtual machine and install the game on that.
My dad uses the same method to run older programs on his windows 7 machine.

I'm running win7 64 bit as well.

#15 israel102

israel102

    New Conscript

  • Members
  • Pip
  • 6 posts

Posted 14 September 2010 - 11:26 PM

and are you able to run ra2 on your 64bit windows 7?

#16 noobLit

noobLit

    Lieutenant

  • Members
  • PipPipPipPipPip
  • 671 posts

Posted 14 September 2010 - 11:56 PM

I am running ra2 on my 64bit Win7 with an i3 with no problems at all.

#17 FReQuEnZy

FReQuEnZy

    Retired

  • Members
  • PipPipPipPipPipPipPip
  • 7986 posts

Posted 15 September 2010 - 12:47 AM

and are you able to run ra2 on your 64bit windows 7?


Yes it runs fine. Besides the usual bugs that come with the game.

The problem that you have described here in this topic does indeed sound like one that of graphics related.

Try disabling windows aero or enable the compatibility option ''disable desktop composition'' for Red Alert 2.

Edited by iNs0MNiaC, 15 September 2010 - 12:50 AM.


#18 lookslikeyou

lookslikeyou

    New Conscript

  • Members
  • Pip
  • 5 posts

Posted 16 September 2010 - 01:17 PM

Tryed the options you described, but still red alert 2 does not work. Even tryed a .reg file i found on the internet.
Im running out of options because when I try to install windows xp with a virtual pc he doesn't recognize my internal gpu. It only
works for programs

#19 FReQuEnZy

FReQuEnZy

    Retired

  • Members
  • PipPipPipPipPipPipPip
  • 7986 posts

Posted 17 September 2010 - 02:54 PM

Google ''windows 7 xp mode''. ;)

It should come in a downloadable update for your computer.


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users