Jump to content


Photo

The First Decade LAN issue!


  • Please log in to reply
6 replies to this topic

#1 adi518

adi518

    Corporal

  • Members
  • PipPip
  • 27 posts
  • Location:Israel
  • XWIS Name: adi518

Posted 02 September 2010 - 08:11 PM

Hi,

I recently bought TFD and I think it's the latest version (1.002). It says on the box "IPX/TCP-IP Compliant". However RA2/YURI doesn't seem to have TCP-IP support, I try to click "Network" and then it quickly goes back to main menu. Thing is, I know there's a patch that replaces the old IPX but at the same time it conflicts with the Internet feature of the game which now works for me since I have a legit serial. I googled some and found out someone made separate launchers for TS/RA2/YURI that disables the LAN patch when you want to play TS/RA2/YURI on the Internet. Problem is, firstly, why doesn't TFD fixes the TCP-IP stuff? I mean, they made it work on XP so why not mend that problem too? Second, I tried to get the launchers someone made but all I found were some broken links so if someone can provide a mirror I'd be glad. Last thing that interests me, I found out about an unofficial 1.003 patch for TFD which says it fixes LAN/Online play but I also read some stuff which made me unsure if it really just add that dll to support LAN play (neglecting Online) or does both? meaning fixing LAN play while maintaining online play?

Edited by adi518, 02 September 2010 - 08:16 PM.


#2 NeoGrant

NeoGrant

    Commander

  • Members
  • PipPipPipPipPipPipPipPip
  • 14914 posts
  • XWIS Name: neo

Posted 02 September 2010 - 08:28 PM

Microsoft supported IPX up to XP, but they didn't support Vista, and WIN7, which AFAIK makes network games impossible.

AFAIK there is the 1.03 TFD patch that includes the LAN wsock32.dll patch, but as you say that conflicts with XWIS online play, causing black screens at the start of the game, disconnecting etc etc. I believe there is a 1.04 TFD patch in progress thanks to the Command and Patch website, hosted by CNCNZ.

The only temporary fix until then is to move the wsock32.dll patch out of your RA2 folder when you wish to play online XWIS, and move it back in when you want to play LAN games.

#3 adi518

adi518

    Corporal

  • Members
  • PipPip
  • 27 posts
  • Location:Israel
  • XWIS Name: adi518

Posted 02 September 2010 - 09:05 PM

After some wandering about I installed 1.03 patch and tried joining an Online (Internet) game, game started and half a minute after, it gave me this "reconnection error" which often happens on LAN games (using Tunngle/Hamachi) when some players didn't confirm they can see all other players before the game started.

I really appreciate the quick reply, didn't think it'd be both fast and informative!

What I need to get now are those launchers I mentioned before (should solve the problem, at least until 1.004) if someone has these and able to rehost them, it'll be great!

Edited by adi518, 02 September 2010 - 09:08 PM.


#4 NeoGrant

NeoGrant

    Commander

  • Members
  • PipPipPipPipPipPipPipPip
  • 14914 posts
  • XWIS Name: neo

Posted 02 September 2010 - 09:12 PM

After some wandering about I installed 1.03 patch and tried joining an Online (Internet) game, game started and half a minute after, it gave me this "reconnection error" which often happens on LAN games (using Tunngle/Hamachi) when some players didn't confirm they can see all other players before the game started.

I really appreciate the quick reply, didn't think it'd be both fast and informative!

What I need to get now are those launchers I mentioned before (should solve the problem, at least until 1.004) if someone has these and able to rehost them, it'll be great!

Yes, 1.03 still has this issue with online play so when 1.04 is out hopefully we should see results. Regarding the launchers I'm not sure, I'll have to have a look around.

#5 adi518

adi518

    Corporal

  • Members
  • PipPip
  • 27 posts
  • Location:Israel
  • XWIS Name: adi518

Posted 02 September 2010 - 09:30 PM

Btw, I just noticed I applied 1.003 rev 2 while there's actually a 1.003 rev 4 out. The main site (GameSector) hosting the patch is a forum currently under maintenance so if anyone needs it, it's downloadable from here:

http://files.cncsector.net/tfd/
http://files.cncsector.net/tfd/tfd-103-rev4.exe

patch info: http://www.cncforums.com/new/showthread.php?t=2026
it was released around april 2009.

It might fix the online issue.

Edited by adi518, 02 September 2010 - 09:34 PM.


#6 adi518

adi518

    Corporal

  • Members
  • PipPip
  • 27 posts
  • Location:Israel
  • XWIS Name: adi518

Posted 02 September 2010 - 10:27 PM

Hmmm...I just tried to play an internet match and the game just keeps giving me this annoying "reconnection error" I think the patch is causing that...only god knows how to uninstall it now. :\

#7 NeoGrant

NeoGrant

    Commander

  • Members
  • PipPipPipPipPipPipPipPip
  • 14914 posts
  • XWIS Name: neo

Posted 02 September 2010 - 10:29 PM

Hmmm...I just tried to play an internet match and the game just keeps giving me this annoying "reconnection error" I think the patch is causing that...only god knows how to uninstall it now. :\

Move wsock32.dll out of the RA2 directory for Internet play.


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users