Jump to content


Photo

Internal error Tiberian Sun


  • Please log in to reply
5 replies to this topic

#1 agentoj

agentoj

    New Conscript

  • Members
  • Pip
  • 8 posts

Posted 25 January 2010 - 04:53 AM

I get an internal error nearly 2/3 the time i play tiberian sun. I've gone through the help forums and tried all the methods people have advised, but nothing seems to help! The errors don't appear to have anything to do with lag because they happen at all points of the game.... 10 minutes in, 30 minutes in, an hour in. I've noticed they almost always happen when I'm using the "speed scroll" feature (holding right mouse and scrolling), but surely my video card can't cause TS to crash can it?? Here's what I've tried:

1. turning off all programs
2. after starting TS, going in task manager, and setting .exe files to affinity of 1
3. going into startup boot menu and setting vram as high as it will go (128 mb)
4. turning down hardware accelerator to setting 4 (setting 3 or lower, you can't see ts when you start it up)
5. going into the properties of the sun.exe and game.exe files and setting them to windows 98 compatible
6. setting resolution to 1024x768
7. entering "stretchmovies=no" line in sun.ini file
8. reinstall
9. i have both tiberian sun original CD and C&C decade, both installs of TS and i get internal error 60% of my games

My computer is a 1.6 ghz and i have 2.5 gigabits of RAM, i can't imagine it's not capable of handling the game. Can someone please help me figure out what I need to do to make this game work??

#2 NeoGrant

NeoGrant

    Commander

  • Members
  • PipPipPipPipPipPipPipPip
  • 14914 posts
  • XWIS Name: neo

Posted 29 January 2010 - 02:01 PM

I get an internal error nearly 2/3 the time i play tiberian sun. I've gone through the help forums and tried all the methods people have advised, but nothing seems to help! The errors don't appear to have anything to do with lag because they happen at all points of the game.... 10 minutes in, 30 minutes in, an hour in. I've noticed they almost always happen when I'm using the "speed scroll" feature (holding right mouse and scrolling), but surely my video card can't cause TS to crash can it?? Here's what I've tried:

1. turning off all programs
2. after starting TS, going in task manager, and setting .exe files to affinity of 1
3. going into startup boot menu and setting vram as high as it will go (128 mb)
4. turning down hardware accelerator to setting 4 (setting 3 or lower, you can't see ts when you start it up)
5. going into the properties of the sun.exe and game.exe files and setting them to windows 98 compatible
6. setting resolution to 1024x768
7. entering "stretchmovies=no" line in sun.ini file
8. reinstall
9. i have both tiberian sun original CD and C&C decade, both installs of TS and i get internal error 60% of my games

My computer is a 1.6 ghz and i have 2.5 gigabits of RAM, i can't imagine it's not capable of handling the game. Can someone please help me figure out what I need to do to make this game work??

Try running the game with less processes as possible.http://xwis.net/forums/index.php?showtopic=43340#game_crash

#3 PowrBombr

PowrBombr

    Seal

  • Members
  • PipPipPipPip
  • 120 posts

Posted 02 February 2010 - 04:45 PM

When your in game press Esc and click game options and turn visual settings to medium, that will stop Internal errors caused my lasers, BUT it wont stop them completely, you get an IE when you scroll around the map whilst a disruptor or a laser is shooting at the bottom of your screen, try not to look at disruptor beams or laser beams, if you do DONT scroll untuill theyve finished shooting.

Theres a patch for it somewhere, ill try dig it out if i can.

#4 agentoj

agentoj

    New Conscript

  • Members
  • Pip
  • 8 posts

Posted 05 February 2010 - 12:07 AM

I appreciate your feedback but none of it helped. I'm happy to report though that I did find a solution! The answer to the problem was the ddraw.dll which apparently was created by accident by the TS modding community. My errors were occurring not just when there were laser beams and disruptors, but all the time and seemed to be mostly related to using the speed-scrolling. This .dll file supposedly is just used to prevent "wave class internal errors" caused by disruptors and lasers, but it helped me too. Since I put the ddraw.dll file in my Sun directory, I've only had 1 IE in about 50 games. I've literally seen the game trying to freeze while scrolling and it actually will for a split second, but just when I think it's going to internal error, something that ddraw.dll file is doing allows the game to power through it. Life is good.

heres a link :

http://www.ppmsite.com/forum/viewtopic.php...****&t=19543

#5 PowrBombr

PowrBombr

    Seal

  • Members
  • PipPipPipPip
  • 120 posts

Posted 06 February 2010 - 05:42 AM

yup thats the one by CCHyper, wheres a waveclass error that cannot be fixed TBH, the patch youve used there is a temporary fix for disruptors only, thats why your getting less of the IE's. However, you still get them from lasers, turning the visual settings to medium prevents IE's from lasers, so i strongly advise you to do it. CCHyper isnt releasing a fix for all IE's i dont think, ill have to get onto him about it, but what he has released there is all we have for now.

Happy gaming.

#6 kookee

kookee

    New Conscript

  • Members
  • Pip
  • 1 posts

Posted 14 February 2010 - 02:42 AM

When your in game press Esc and click game options and turn visual settings to medium, that will stop Internal errors caused my lasers, BUT it wont stop them completely, you get an IE when you scroll around the map whilst a disruptor or a laser is shooting at the bottom of your screen, try not to look at disruptor beams or laser beams, if you do DONT scroll untuill theyve finished shooting.

Theres a patch for it somewhere, ill try dig it out if i can.



http://www.ppmsite.com/forum/download.php?id=24351

just drop it into the SUN dir


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users