Jump to content


Photo

RA2 Lag, Choppy/Slow Gameplay


  • This topic is locked This topic is locked
1 reply to this topic

#1 Pizzaguru

Pizzaguru

    Seal

  • XWIS Buddies
  • PipPipPipPip
  • 467 posts
  • Location:The Netherlands
  • XWIS Name: PizzaGuru

Posted 05 April 2009 - 07:04 PM

If your games lag (average fps < 40) you can probably improve it by trying the following 10 tricks. It's listed by easiest, most effective solutions

- - - 1. - - -
Scan for virusses, trojans, spyware

- - - 2. - - -
Defrag your harddrive

- - - 3. - - -
Go to task manager(Ctrl+Shift+Esc) and look for processes with a high memory usage. Closing these might help.

- - - 4. - - -
Re-install Ra2 & YR


- - - 5. - - -
Use an other (lower) resolutions



If this didn't fix your lag, the lag probably caused Ra2 itself. Try the following:

- - - 6. - - -
Solution:
In ra2(md).ini add;
[Video]
VideoBackBuffer=no

Info:
game lag is literally all in the game code and in the way is handles rendering objects on the screen. The software wants to render instead of using DirectDraw but DD tries to do it anyway and bogs the game down with unnecessary actions. This modified DLL has a high success rate of reducing lag on most configurations. However, it's not 100% since a few machines here and there experience a black screen with audio and mouse input but no video. That means it does not work on your configuration. However, I am completely unsure of the success rate on Windows Vista but I know it's higher on Windows XP of both flavors.

- - - 7. - - -
Turn off hardware acceleration (http://www.pixelmetrics.com/Tips/VidBlank/...cceleration.php)
Info: Some RA2/YR players may experience dramatic in-game slowdowns during special effects, ie:
- Structures blowing up
- Prism tanks firing
- Using super weapons
This is due to outdated game code, which makes incorrect assumptions about modern video cards. Disabling hardware acceleration may negatively affect overall performance somewhat, but will also drastically reduce - if not completely eliminate - these slowdowns. Try running RA2/YR with and without this setting, and leave it at whichever works best for you.

- - - 8. - - -
Lag whenever Eva Speaks (1.006)...
Solution: Roll back the language.mix file to a pre-patched version

steps:
  • After updating to version 1.006, open your RA2 folder.
  • Delete language.mix.
  • Reinsert your Red Alert 2 CD.
  • Click Explore CD.
  • Open folder INSTALL.
  • Open Game1.
  • Copy this language.mix to your RA2 folder.

Info:
One works for most. One works for all. The patch modifies the file. On some computers, the modification makes the audio and video components fall out of sync. For instance, the mission briefings are like watching a foreign film. You see the actors' lips moving, but their words are delayed. The missions themselves lag whenever the lieutenants speak, "Building, construction complete, new construction options, ore miner under attack, training, unit ready," etc., so I assume the technician figured the problem was the file that controlled these sounds.

Side-effect:
If with this fix, you can no longer user /r/d and /page
try placing this file in ur ra2 dir
http://ra2maps.net/temp/ra2.csf

- - - 9. - - -
Updating graphic drivers

- - - 10. - - -
Format your harddrive and reinstall the OS

- - - 11. - - -
New graphic card (different chipset)

Edited by neogrant, 30 March 2010 - 12:48 PM.
Number 5 Added 30th March 2010


#2 Pompski

Pompski

    Emilio's Owner

  • Strike Team
  • PipPipPipPipPipPipPipPip
  • 19854 posts
  • Location:Royal Air Force
  • XWIS Name: Pomp

Posted 06 April 2009 - 08:27 AM

Many thanks to pizzaguru for going out of his own way to create this :)


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users