Jump to content

Photo

Black screen


  • Please log in to reply
22 replies to this topic

#1 Niek

Niek

    Veteraan

  • Warning
  • PipPipPipPipPipPipPip
  • 9942 posts

Posted 23 March 2012 - 03:06 PM

Installed Ra2. Things went ok.

When i start up that game i see a black screen. I can hear Ra2 sounds and start a game, but i see a black screen only. It began already with the start of the opening movie.

Help.

Edited by Niek, 23 March 2012 - 04:21 PM.


#2 Niek

Niek

    Veteraan

  • Warning
  • PipPipPipPipPipPipPip
  • 9942 posts

Posted 23 March 2012 - 03:22 PM

Jonja is telling about deleting wsock32.dll in the games directory when having problems with a black screen.

The game directory is when you open up the ra2 icon and 2 maps and some icons pop up right? That's where i looked but didn't find it.

Anyone?

Edited by Niek, 23 March 2012 - 04:32 PM.


#3 fir3w0rx

fir3w0rx

    If we learn from our mistakes, then I must be a genius!

  • XWIS Buddies
  • PipPipPipPipPipPip
  • 1952 posts

Posted 23 March 2012 - 04:35 PM

  • PC or laptop
  • Which Windows
  • Which RA2 (Olaf's/CD/TFD)


#4 Niek

Niek

    Veteraan

  • Warning
  • PipPipPipPipPipPipPip
  • 9942 posts

Posted 23 March 2012 - 05:59 PM

Pc
Windows 7
Cd

Edited by Niek, 23 March 2012 - 06:45 PM.


#5 JonasAKAFaze

JonasAKAFaze

    The BH Master

  • Bounty Hunters
  • PipPipPipPipPipPip
  • 1035 posts
  • Location:Denmark
  • XWIS Name: Jonas

Posted 23 March 2012 - 08:24 PM

Jonja is telling about deleting wsock32.dll in the games directory when having problems with a black screen.

The game directory is when you open up the ra2 icon and 2 maps and some icons pop up right? That's where i looked but didn't find it.


Check my attached file. And there's no need to delete it. Just move it to your desktop or something.
Otherwise use Olaf's :)

Attached Thumbnails

  • ggg.JPG


#6 FReQuEnZy

FReQuEnZy

    CnCFTW Team Leader

  • Members
  • PipPipPipPipPipPipPip
  • 6780 posts

Posted 23 March 2012 - 09:25 PM

Uninstall CD Version of RA2.

Download MP only from here http://xwis.net/downloads/Red_Alert-2-0.0.0.exe.

Install it, then download and install my optimizer from here http://www.mediafire.com/?lbsppzaqlx394ln

Browse to your red alert 2 folder @ program files(x86) and make a desktop shortcut for ''red alert 2.exe''.

My optimizer installs a patched exe of Olaf's auto ss uploader which should fix the black screen problem.

Let me know if it doesn't work and I'll send you the exe patcher.

#7 Niek

Niek

    Veteraan

  • Warning
  • PipPipPipPipPipPipPip
  • 9942 posts

Posted 23 March 2012 - 10:10 PM

Downloading that optimizer seems a problem.

After 10 tries i got it and installed it. Still black screen.


Check my attached file. And there's no need to delete it. Just move it to your desktop or something.
Otherwise use Olaf's :)


It is where i looked, strangely it wasn't there. Thx for help.

Edited by Niek, 23 March 2012 - 10:23 PM.


#8 FReQuEnZy

FReQuEnZy

    CnCFTW Team Leader

  • Members
  • PipPipPipPipPipPipPip
  • 6780 posts

Posted 23 March 2012 - 10:29 PM

Did you follow every step and downloaded MP only then launched red alert 2.exe?

#9 Niek

Niek

    Veteraan

  • Warning
  • PipPipPipPipPipPipPip
  • 9942 posts

Posted 23 March 2012 - 10:44 PM

Uninstalling was a bit of a problem. Dont think it is uninstalled



Working on things i'll send some prntscreen picture's tomorrow to let you see what could be wrong :S

If i click "next" on picture number 2 it goes to pic number 3, when i click on that button again it disappears in an instance without beginning the uninstalling process.

Attached Thumbnails

  • 2.jpg
  • 3.jpg
  • 4.jpg
  • 5.jpg
  • 6.jpg

Edited by Niek, 23 March 2012 - 11:11 PM.


#10 Niek

Niek

    Veteraan

  • Warning
  • PipPipPipPipPipPipPip
  • 9942 posts

Posted 23 March 2012 - 11:14 PM

This is your picture Faze

Attached Thumbnails

  • 7.jpg


#11 JonasAKAFaze

JonasAKAFaze

    The BH Master

  • Bounty Hunters
  • PipPipPipPipPipPip
  • 1035 posts
  • Location:Denmark
  • XWIS Name: Jonas

Posted 23 March 2012 - 11:32 PM

Maybe if you update ra2 to 1.006, the file might appear.
Or try to download http://www.gamefront.com/files/?filepath=/moddb/2009/03/14/wsock32.zip
- Put it in ra2 folder, start a game, and if the black screen still appears, take it out of the folder and retry.

I don't have any other solutions :p

#12 fir3w0rx

fir3w0rx

    If we learn from our mistakes, then I must be a genius!

  • XWIS Buddies
  • PipPipPipPipPipPip
  • 1952 posts

Posted 24 March 2012 - 12:12 AM

-Set your desktop display to 16bit color before running RA2
-Start the game as admin.

If that doesn't work, install the multiplayer-only version (Red Alert 2.0.0.0) from the Downloads section above, don't forget to start it as admin. Don't worry about uninstalling.

Btw, are you using an ISO? It looks like you are and that's probably why it can't find your D: drive. I don't think you need to uninstall it, but if you want to anyway, uninstall it from Control Panel -> Programs and Features.

#13 FReQuEnZy

FReQuEnZy

    CnCFTW Team Leader

  • Members
  • PipPipPipPipPipPipPip
  • 6780 posts

Posted 24 March 2012 - 01:40 AM

-Set your desktop display to 16bit color before running RA2
-Start the game as admin.

If that doesn't work, install the multiplayer-only version (Red Alert 2.0.0.0) from the Downloads section above, don't forget to start it as admin. Don't worry about uninstalling.

Btw, are you using an ISO? It looks like you are and that's probably why it can't find your D: drive. I don't think you need to uninstall it, but if you want to anyway, uninstall it from Control Panel -> Programs and Features.


The display color mode is not needed, it's a graphics rendering bug/problem that is fixed by software emulation.
I've succeeded in replicating the problem on my own system.

Most applications should be ran as admin to ensure best compatibility.


Fireworks I've seen your attempts at help in many topics and you give a lot of false information that will end up confusing the user.
Could you please stop posting what you assume and post what you know 100%.

He needs to uninstall the original game to ensure compatibility and to reduce the chance of any other errors occurring.
From the screenshots you can see that he's missing the uninstaller or has errors with it, meaning the programs and features section wouldn't work as it uses the same method for uninstalling programs.


Niek, just delete the folder of the game with it's contents and then run Ccleaner to wipe any residual files and then run it's registry cleaner as well.
After that you can install the MP only version knowing there shouldn't be a problem.

#14 tbiol

tbiol

    Captain

  • Help Team
  • PipPipPipPipPipPip
  • 2466 posts
  • Location:Chicagoland
  • XWIS Name: tbiol

Posted 24 March 2012 - 01:41 AM

Run as administrator?

I can no longer play the downloaded version without running as administrator.

Edited by tbiol, 24 March 2012 - 01:42 AM.


#15 fir3w0rx

fir3w0rx

    If we learn from our mistakes, then I must be a genius!

  • XWIS Buddies
  • PipPipPipPipPipPip
  • 1952 posts

Posted 24 March 2012 - 02:46 AM

Fireworks I've seen your attempts at help in many topics and you give a lot of false information that will end up confusing the user.
Could you please stop posting what you assume and post what you know 100%.

He needs to uninstall the original game to ensure compatibility and to reduce the chance of any other errors occurring.
From the screenshots you can see that he's missing the uninstaller or has errors with it, meaning the programs and features section wouldn't work as it uses the same method for uninstalling programs.

Well, since I don't know much, people will have to go with what I assume (which sometimes actually works) :D! Besides, I'm not forcing anyone to listen to my genius advice. Also, ST is not an official PC help forum, so people should know that any advice they take from here are taken at their own risk. So if they want to listen to me... good luck :laugh:!

Regarding uninstalling, I have 3 different copies of RA2 installed on both my XP and Win 7 PCs with no problems. But hey, idc, whatever works for the guy. From now on, I'll put a disclaimer beneath all my advice, kapish sir?







Any advice from Fireworks is taken at your own risk! ...and Frequenzy's a grumpy dude.

Edited by Fireworks, 24 March 2012 - 02:58 AM.


#16 Niek

Niek

    Veteraan

  • Warning
  • PipPipPipPipPipPipPip
  • 9942 posts

Posted 24 March 2012 - 09:02 AM

I'm more than satisfied with the help everyone has to offer. Going to work further on it. I quess i'll download Ccleaner in this matter.

Whatever i do with Ccleaner it doesn't get me Ra2 away.

Maybe caus this comp is secured.

Edited by Niek, 24 March 2012 - 10:13 AM.


#17 Niek

Niek

    Veteraan

  • Warning
  • PipPipPipPipPipPipPip
  • 9942 posts

Posted 24 March 2012 - 10:19 AM

Friggin Computers I HATE THEM SO MUCH!!!


GOnna wait a couple OF MONTHS AND ILL BUY MY OWN COMPUTER!!



AAAAAAAAAAAAAAAAAAAAAAAAAAAAARG. ALL THE EFFORT!

if you want to erase things on comp why can't you use a hammer! im good with hammers, better than with COMPUTERS AAAAAAAAAAAAAAAAAAAAAAAAAAAAAARG! :cursing:

#18 fir3w0rx

fir3w0rx

    If we learn from our mistakes, then I must be a genius!

  • XWIS Buddies
  • PipPipPipPipPipPip
  • 1952 posts

Posted 24 March 2012 - 10:24 AM

Have you tried uninstalling it through Start -> Control Panel -> Programs and Features ? What about installing the Olaf's version in a different folder to the one that you are currently using?





Disclaimer: Fireworks rox!

#19 Niek

Niek

    Veteraan

  • Warning
  • PipPipPipPipPipPipPip
  • 9942 posts

Posted 24 March 2012 - 10:26 AM

FReQuEnZy using Ccleaner doesn't get my files away, they are still there.


Thanks for help EVERYONE. I'm going to do other things to keep myself bizzy today with other things instead of the impossible.

Have you tried uninstalling it through Start -> Control Panel -> Programs and Features ? What about installing the Olaf's version in a different folder to the one that you are currently using?





Disclaimer: Fireworks rox!


I'm looking into it after my Coffee!

Trying to get a whizzkid up here. I'm mentally disorganized.

Edited by Niek, 24 March 2012 - 10:51 AM.


#20 FReQuEnZy

FReQuEnZy

    CnCFTW Team Leader

  • Members
  • PipPipPipPipPipPipPip
  • 6780 posts

Posted 24 March 2012 - 01:31 PM

so people should know that any advice they take from here are taken at their own risk. So if they want to listen to me... good luck :laugh:!

Frequenzy's a grumpy dude.


I'm grumpy because I have to post and think twice as much for helping some one. I will need to help the OP then discredit useless and misguiding posts and the OP will need to work twice or thrice to test all the wrong solutions. So take a hint and act your age.


You used to be a lot more mature before you became a xwis buddy.

@ Niek, give me your MSN?

Edited by FReQuEnZy, 24 March 2012 - 01:33 PM.


#21 fir3w0rx

fir3w0rx

    If we learn from our mistakes, then I must be a genius!

  • XWIS Buddies
  • PipPipPipPipPipPip
  • 1952 posts

Posted 24 March 2012 - 01:42 PM

I'm grumpy because I have to post and think twice as much for helping some one. I will need to help the OP then discredit useless and misguiding posts and the OP will need to work twice or thrice to test all the wrong solutions. So take a hint and act your age.


http://www.youtube.com/watch?v=LTGdAGPDBpo

Sorry but I couldn't help it. That's^ the last wise crack from me (for a while). I don't want to act my age coz that'll mean I'll have to stop playing video games, but I will try to be more mature.

#22 Niek

Niek

    Veteraan

  • Warning
  • PipPipPipPipPipPipPip
  • 9942 posts

Posted 24 March 2012 - 03:14 PM

niekoudeelferink@hotmail.com

Downloading messenger now ..

whizzkid is called, he didn't ring the phone


I settled down a labtop. I get in the "false" bunker everytime.

Edited by Niek, 24 March 2012 - 03:58 PM.


#23 Tomi

Tomi

    Mr. Rank 1

  • Members
  • PipPipPipPipPipPipPip
  • 8346 posts

Posted 26 March 2012 - 10:44 AM

bad boys bad boys what you gonna do, gotta love smith and lawrence, epic.

Edited by Tomi, 26 March 2012 - 10:52 AM.



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users